A random sentence for a random mind.

Fixing super-speed UT and mouse issues.

For gameplay advice and broader discussion of single-player Unreal including custom maps, mods and mutations that alter the game.

Moderators: ividyon, Semfry, zYnthetic

redeye
Banned Banned
Posts: 1393
Joined: 08 Dec 2007, 06:55

Subject: Re: Fixing super-speed UT

Post Posted: 08 Jan 2011, 08:18

medor wrote:You haven't try my UT ?

just try this
UseVSync=False
FrameRateLimit=190


Well the "nvidia" profile stuff messes with it, games run on a tick rate, there is no need to show more frames beyond the engine tick rate.
New systems run so good, setting framerate to 60, 75 Hertz will be plenty of headroom over engine ticks.
I prefer to set it to be equal to my monitor, in that way, every move you make in-game will be dead on compared to the video rendering speed, but have plenty of CPU/GPU power at hand..
Just ban everyone

medor
Skaarj Lord Skaarj Lord
Posts: 151
Joined: 07 Jun 2009, 22:58

Subject: Re: Fixing super-speed UT

Post Posted: 08 Jan 2011, 08:31

so

UT.ini

[WinDrv.WindowsClient]
WindowedViewportX=876
WindowedViewportY=681
WindowedColorBits=32
FullscreenViewportX=800
FullscreenViewportY=600
FullscreenColorBits=32
Brightness=0.300000
MipFactor=1.000000
UseDirectDraw=True
UseJoystick=False
CaptureMouse=True
StartupFullscreen=True
CurvedSurfaces=False
LowDetailTextures=0
ScreenFlashes=False
NoLighting=False
SlowVideoBuffering=False
DeadZoneXYZ=True
DeadZoneRUV=True
InvertVertical=False
ScaleXYZ=1000.000000
ScaleRUV=2000.000000
MinDesiredFrameRate=75.000000 75 for me
Decals=False
NoDynamicLights=False
UseDirectInput=False
ParticleDensity=0
NoFractalAnim=True
SkinDetail=High
TextureDetail=High

User avatar Semfry
Trustee Member Trustee Member
Posts: 1988
Joined: 12 Nov 2007, 02:43
Location: UK
Contact:

Subject: Re: Fixing super-speed UT

Post Posted: 01 Mar 2011, 19:22

Just a small update that I got a brand new computer with an Intel i5 2500k CPU and UT seems to work perfectly just copying my old installation over. So I can confirm that the newest Intel CPU's still only seem to need the framerate cap to work.
Formerly Mman

User avatar Buff Skeleton
>:E >:E
Posts: 4069
Joined: 15 Dec 2007, 00:46

Subject: Re: Fixing super-speed UT

Post Posted: 01 Mar 2011, 20:39

medor wrote:MinDesiredFrameRate=75.000000 75 for me

Keep in mind that this is the DropDetail setting, which means that extra visual effects will NOT be spawned if your framerate goes below 75. It's designed to stabilize your FPS somewhat when a lot of stuff is going on at once. Really, setting it above 30 is extreme, and it means you will see a lot less of the nicer effects much more often, even times when dropping detail doesn't really add much benefit.
Image

User avatar Semfry
Trustee Member Trustee Member
Posts: 1988
Joined: 12 Nov 2007, 02:43
Location: UK
Contact:

Subject: Re: Fixing super-speed UT

Post Posted: 01 Mar 2011, 23:28

Yeah, on any semi-modern PC you can probably set that to zero (or thirty maximum), and never have issues with framerate outside of the most advanced or unoptimised levels (where it probably won't help much anyway).
Formerly Mman

User avatar Bombadilian
Skaarj Lord Skaarj Lord
Posts: 198
Joined: 23 Oct 2008, 01:02
Location: Spawning Nalis in DMAriza and then taunting them with a rifle for my own amusement

Subject: Re: Fixing super-speed UT

Post Posted: 19 Dec 2011, 20:17

Having this problem again.

The weird thing is...when I installed Unreal on my laptop, it ran at super speed until I installed the Oldunreal 227f patch.

Now, on this computer, it was running fine before I installed the same patch, which is causing it to run at super speed.

GAH!
'Well, there goes our grant money.'

User avatar Psychomorph
Skaarj Assassin Skaarj Assassin
Posts: 141
Joined: 17 Jul 2008, 16:46

Subject: Re:

Post Posted: 20 May 2012, 22:33

Mman wrote:Seems like all I needed was the framerate fix to get UT working properly on my Intel computer.

Yeah, I wish I knew that earlier. I had many problems in Infiltration, like hitting surfaces (incl. water) made me stick to it and warp around, sprinting made me warp back, crawling prone made me warp back to where I started once done and all this stuff, but now all that is fixed. Thanks.

I still have an odd problem though. I have two mice, Zowie AM and Razer Diamondback 3G. I use AM with 450dpi and adjusted my 1st person games to have a 180° turn when moving the mouse 20cm over the pad (low sense gamer). Diamondback has only 800dpi, so I lowered the sensitivity in the software to have the same mouse speed as the AM. In Quake Live, Half-Life 1 and Half-Life 2 both mice have the same speed, but in Unreal, UT and Infiltration the Diamondback is faster (15cm for 180°, while AM still 20cm for 180°). Wonder what the cause is.
Image

User avatar Semfry
Trustee Member Trustee Member
Posts: 1988
Joined: 12 Nov 2007, 02:43
Location: UK
Contact:

Subject: Re: Fixing super-speed UT

Post Posted: 20 May 2012, 23:04

For mouse weirdness (in Windows 7 at least), try this http://donewmouseaccel.blogspot.co.uk/2 ... n-fix.html

Just download the fix and run the registry file for whatever DPI your computer is at (probably 100%) and restart. Newer versions of Windows have a weird mouse acceleration curve that is very noticeable in some games (and older Unreal engine games seem to be particular offenders). The fix smoothes it out, which might fix your issue, and, either way, it will improve general mouse consistency in games.
Formerly Mman

User avatar Psychomorph
Skaarj Assassin Skaarj Assassin
Posts: 141
Joined: 17 Jul 2008, 16:46

Subject: Re: Fixing super-speed UT

Post Posted: 21 May 2012, 00:38

Thanks, both mice have the same speed now, but unfortunately there is negative acceleration in Unreal/UT for me.

I played some Quake Live and Counter Strike 1.6 a bit and both mice perform the same or similar and feel good, in Unreal and UT it feels odd to look around, not very smooth.
Image

User avatar StalwartUK
Skaarj Berserker Skaarj Berserker
Posts: 336
Joined: 11 Nov 2007, 21:31
Location: UK

Subject: Re: Fixing super-speed UT

Post Posted: 04 Jul 2012, 08:31

Awesome fix. I was never too happy with the often wonky mouse acceleration curve Windows XP+ had.
StalwartUK
Recent plays: New Alcatraz, 13 Mutants, Thrall Village, Déjà Vu - Gryphon Revisited 1.01, Unreal v200, Unreal: Return to Na Pali v224, The Triamid Ruins, Enslaved, Unreal II: The Awakening, Project: Xenome: Interloper

User avatar Mister_Prophet
Red Nemesis Leader Red Nemesis Leader
Posts: 2876
Joined: 11 Nov 2007, 23:30
Location: Long Island, New York

Subject: Re: Fixing super-speed UT

Post Posted: 11 Jul 2012, 04:19

Okay so I'm having a super-speed/Super-slow issue with a laptop, testing a vanilla set of maps through UT. My situation is a bit different than those mentioned in this thread since this is a laptop that I purposely have set NOT configured for the internet, running Windows XP as an OS. I'm playing these levels in software rendering, and it seems to be random when it goes in and out of these extreme speeds (sometimes the levels will run normally). Obviously I can't download anything to make fix. Suggestions?
Image

User avatar Mister_Prophet
Red Nemesis Leader Red Nemesis Leader
Posts: 2876
Joined: 11 Nov 2007, 23:30
Location: Long Island, New York

Subject: Re: Fixing super-speed UT

Post Posted: 22 Jul 2012, 14:51

Nothing huh? :) Figured it would be a tough fix.
Image

User avatar ividyon
Administrator Administrator
Posts: 2269
Joined: 12 Nov 2007, 14:43
Location: Stuttgart, Germany
Contact:

Subject: Re: Fixing super-speed UT

Post Posted: 22 Jul 2012, 15:05

Why are you running Software? Do you not have any access to a USB stick/CD burner you can load some patches and renderers onto?
UnrealSP.org webmaster & administrator

ImageImage

User avatar Buff Skeleton
>:E >:E
Posts: 4069
Joined: 15 Dec 2007, 00:46

Subject: Re: Fixing super-speed UT

Post Posted: 22 Jul 2012, 15:49

If the laptop has a multi-core CPU, try setting the affinity to only one core ingame (pain in the ass to do each time but see if it helps at all). I've never had UT speed problems on XP, but maybe with the right hardware even XP can cause problems. My weird speed issues were always on Vista while I was forced to use it for a few years before switching to Win7.

What kind of hardware is in the laptop? Does it have some kind of Cool 'n Quiet thing enabled in the BIOS that would downclock the processor dynamically according to usage? Might need to disable features like that or other power management things.
Image

User avatar []KAOS[]Casey
Skaarj Berserker Skaarj Berserker
Posts: 425
Joined: 25 Sep 2008, 07:25

Subject: Re: Fixing super-speed UT

Post Posted: 23 Jul 2012, 07:58

His issue is probably the framerates going above 120 in really small areas such as looking only at a wall, which can't be fixed without an FPS limiter of some kind, and Software doesn't have VSync so... yeah..

Previous Next

Who is online

Users browsing this forum: No registered users and 7 guests