A random sentence for a random mind.

Fixing super-speed UT and mouse issues.

For gameplay advice and broader discussion of single-player Unreal including custom maps, mods and mutations that alter the game.

Moderators: Semfry, zYnthetic, ividyon

User avatar Semfry
Trustee Member Trustee Member
Posts: 2002
Joined: 12 Nov 2007, 02:43
Location: UK
Contact:

Subject: Fixing super-speed UT and mouse issues.

Post Posted: 24 Mar 2008, 02:16

After making my new, far better computer I suffered from the problem of the game running at superspeed. I tried stuff like Vsynch and the OpenGL frame rate limit option but that did nothing. After some more searching I discovered that things had to be done in a certain order and it was a combination of things that caused it/could fix it. So I've brought together the steps I took for it so it shouldn't be an issue for anyone anymore.

This guide assumes you are using a variant of Chris Dohnal's OpenGL/Direct3D 8 drivers. These detailed steps are for an AMD PC. Intel PC's should only require the frame rate limit

Note that overclocking probably contributes too, but as I haven't touched that I can't comment on it.

Step 1: Cool and quiet

If you have the "cool and quiet" function turned on then UT will not work properly whatever you do with the next two steps. If you have to ask what this is then it probably isn't an issue, but if you want to make sure go to the power saving area on the screensaver tab when you open properties on the desktop and make sure the power profile is NOT set to "minimal power consumption". That's how it works for me anyway.

If you like having it on (I certainly do as it doesn't seem to affect modern games and does seem to have a noticable effect) then you'll just have to remember to switch it back on after.

Intel apparently has its own version of this, but I have no idea what it's called or any other details.

Step 2: Dual-core fixes

At least part of the problem is related to Dual-core processors. This site has a list of fixes for problems related to this: http://www.hardforum.com/showthread.php?t=983781

Despite what it says in the second post fix#1 instantly fixed my UT problems (after step 1 was done), so since it seems to vary I guess you'll just have to experiment in this regard (since that post was made last year, perhaps fix#1 has since been updated and that's why it works?)

Edit: This seems to be a newer version of the optimiser and a working link (AMD only and Dual-core only): http://support.amd.com/us/Pages/dynamic ... ItemID=153

Note: While it sounds obvious, just in case; DO NOT install the dual-core optimiser if you have three or more cores! The other fixes here should hopefully be enough.

Step 3: Frame rate limit

If you have got steps 1 and 2 done successfully then UT's performance should have at least a small degree of normality when you open it, but there are still some final ingame tweaks before it is fully fixed. In UT's advanced properties (Oldskool lets you access them easily from the menu). On the OpenGL settings in renderer set the "frameratelimit" option to somewhere between 100 and 200 (I currently am using 100, as 200 still gave the gameplay a slightly unnatural feeling for me). I don't know about the equivalent option for Direct3D 8. At this stage, Vsync may work as well, but I haven't tried it.

When I tried this before the other two I got strange performance glitches even in the menu, so leave this step for last.

There, now UT should be back to how it normally feels.

Edit 2: Another fix if speed issues persist on Vista or Windows 7 after the above:

Waffnuffly wrote:I found something else interesting on Vista here at work. If you right click the UT exe, go to Compatibility, and then put a check next to "Disable Desktop Composition," the game no longer runs in turbo mode super speed.


Edit 3: If you're having obviously laggy mouse movement and other issues try this:

Mman wrote:For mouse weirdness (in Windows 7 at least), try this http://donewmouseaccel.blogspot.co.uk/2 ... n-fix.html

Just download the fix and run the registry file for whatever DPI your computer is at (probably 100%) and restart. Newer versions of Windows have a weird mouse acceleration curve that is very noticeable in some games (and older Unreal engine games seem to be particular offenders). The fix smoothes it out, which might fix your issue, and, either way, it will improve general mouse consistency in games.

Turning directinput on/off in the game options may also help
Last edited by Semfry on 01 Mar 2010, 17:30, edited 4 times in total.

User avatar Semfry
Trustee Member Trustee Member
Posts: 2002
Joined: 12 Nov 2007, 02:43
Location: UK
Contact:

Subject:

Post Posted: 24 Mar 2008, 02:18

Reposting (and stickying) from the old forum.

Does anyone know anything you have to do on Intel processors? I need UT running right on my Intel dual-core (it seems slightly less bad than it was on AMD, but I still notice weird speed changes).

User avatar Buff Skeleton
>:E >:E
Posts: 4104
Joined: 15 Dec 2007, 00:46

Subject:

Post Posted: 24 Mar 2008, 03:11

I had this problem (super slow and/or super fast) in UT quite often on my Vista Ultimate 32bit work machine. I don't have ANY issues since installing Vista SP1, but I also managed to alleviate some of the problem (while also causing a drastic loss of FPS) by changing the Power Saving Options on the Control Panel from Balanced to Saver. This made the speed consistent, but it gave choppy performance.

SP1, though, allowed me to revert back to Balanced so the CPU wasn't limited to 50% power at max, unlike under Saver. However, running RTNP with the OldUnreal media patch still requires Saver mode, or else it will run ultra-slow.

As far as high-speed UT with an Intel processor, I've never experienced it. I have a Core2Duo E6750 and have never had problems with UT under XP SP2.

User avatar Semfry
Trustee Member Trustee Member
Posts: 2002
Joined: 12 Nov 2007, 02:43
Location: UK
Contact:

Subject:

Post Posted: 25 Mar 2008, 04:05

Seems like all I needed was the framerate fix to get UT working properly on my Intel computer.

User avatar zYnthetic
Trustee Member Trustee Member
Posts: 507
Joined: 12 Nov 2007, 00:10

Subject:

Post Posted: 26 Mar 2008, 00:31

Mman wrote:Seems like all I needed was the framerate fix to get UT working properly on my Intel computer.

Likewise.
Strangely enough the problem is much more noticeable in 2k4.
Image

User avatar Darkon
White Tusk White Tusk
Posts: 2211
Joined: 12 Nov 2007, 15:11
Location: P46153

Subject:

Post Posted: 26 Mar 2008, 13:43

The weird thing is that only my animated textures are really fast.. does your fix include this? (I have an old computer (2ghz and yes, single core) with an x800 ATI video card, that probably causes this glitch)
there's more

User avatar BoneofMalkav
Skaarj Scout Skaarj Scout
Posts: 15
Joined: 26 Mar 2008, 05:38
Location: In someone's pants....
Contact:

Subject:

Post Posted: 03 Apr 2008, 17:37

zYnthetic wrote:
Mman wrote:Seems like all I needed was the framerate fix to get UT working properly on my Intel computer.

Likewise.
Strangely enough the problem is much more noticeable in 2k4.


Weird,I didn't notice this problem in UT2k4 but of course I have Vsynch enabled in game. :B
"Watch the sun,as it crawls across a final time.And it feels like,like it was a friend.If it's watching us,and the world we set on fire.Do you wonder,if it feels the same?"
NIN-In This Twilight

Ryanx69x
Skaarj Scout Skaarj Scout
Posts: 31
Joined: 06 Sep 2008, 23:24

Subject:

Post Posted: 13 Oct 2008, 16:46

I had this problem on my old comp. I downloaded the dual core fixes for my amd processor and the latest driver on my old comp and it worked fine for a while. But started to fuck up again and i have to clue why lol. I have vista on my new comp and ut works perfectly. Vista has much better support for dual core and quad core processors than xp does, sometimes you might not even need these fixes. I also found out that ATI video cards works much better than Nvida cards with older games. My new computer also now has an ATI card, as opposed to an NVidia card that my older computer had.

User avatar Buff Skeleton
>:E >:E
Posts: 4104
Joined: 15 Dec 2007, 00:46

Subject:

Post Posted: 13 Oct 2008, 16:58

Ryanx69x wrote:I had this problem on my old comp. I downloaded the dual core fixes for my amd processor and the latest driver on my old comp and it worked fine for a while. But started to fuck up again and i have to clue why lol. I have vista on my new comp and ut works perfectly. Vista has much better support for dual core and quad core processors than xp does, sometimes you might not even need these fixes. I also found out that ATI video cards works much better than Nvida cards with older games. My new computer also now has an ATI card, as opposed to an NVidia card that my older computer had.

Haha, this is like the exact opposite of my situation. At home, I have an Nvidia card, Intel dual core CPU, and XP, and UT runs flawlessly. At work, I have a Vista machine with an ATi card and AMD dual core CPU, and I get issues. SP1 seemed to have fixed it (as I posted a while back), but it started fucking up again for seemingly no reason until I set the framerate limit to 150, which doesn't even make much sense. Now UT runs OK at work, but still nowhere near as smoothly as it does for me at home.

Yes, I get paid to play UT and any other game I can get to work on these machines. :p

Ryanx69x
Skaarj Scout Skaarj Scout
Posts: 31
Joined: 06 Sep 2008, 23:24

Subject:

Post Posted: 02 Nov 2008, 16:28

Waffnuffly wrote:
Ryanx69x wrote:I had this problem on my old comp. I downloaded the dual core fixes for my amd processor and the latest driver on my old comp and it worked fine for a while. But started to fuck up again and i have to clue why lol. I have vista on my new comp and ut works perfectly. Vista has much better support for dual core and quad core processors than xp does, sometimes you might not even need these fixes. I also found out that ATI video cards works much better than Nvida cards with older games. My new computer also now has an ATI card, as opposed to an NVidia card that my older computer had.

Haha, this is like the exact opposite of my situation. At home, I have an Nvidia card, Intel dual core CPU, and XP, and UT runs flawlessly. At work, I have a Vista machine with an ATi card and AMD dual core CPU, and I get issues. SP1 seemed to have fixed it (as I posted a while back), but it started fucking up again for seemingly no reason until I set the framerate limit to 150, which doesn't even make much sense. Now UT runs OK at work, but still nowhere near as smoothly as it does for me at home.

Yes, I get paid to play UT and any other game I can get to work on these machines. :p


Lol that is weird. Well I guess that it really depends on what card you get. But, I know for a fact that Vista is supposed to have better support for dual core processors.

User avatar zacman
Skaarj Warlord Skaarj Warlord
Posts: 690
Joined: 23 Jun 2009, 02:51
Location: Under your bed with a Chainsaw

Subject:

Post Posted: 12 Jul 2009, 07:00

Here's something to fix it on laptops: I had my laptop on High Power, and the speed went thru the roof, but I set it to FULL power and it was normal again. Serious WTF... Full power DOUBLES the CPU speed, but makes UT slower...
ImageImage

Code: Select all

(11:32:26) Shivaxi: i love fat girls

Code: Select all

(03:01:24 PM) <+All_Rights_Reserved> i'm not masturbating

User avatar Buff Skeleton
>:E >:E
Posts: 4104
Joined: 15 Dec 2007, 00:46

Subject:

Post Posted: 21 Jan 2010, 20:09

I found something else interesting on Vista here at work. If you right click the UT exe, go to Compatibility, and then put a check next to "Disable Desktop Composition," the game no longer runs in turbo mode super speed.

I'd already tried the AMD Dual Core Optimizer, the framerate limit of 200, and setting the processor power state to 100% at all times, but none of this helped (for one of the machines). This other option, though, did magic.

I think it's got something to do with the way the OS uses hardware acceleration to run the Aero theme. When you disable desktop composition, while UT is running, your visual theme gets reverted to a very basic version of Aero, but the game runs fine.

If any of you are having speed issues with Vista (or Win7), give this a try. It's not perfect, but it helps a ton.

User avatar gatecrasher48
Skaarj Scout Skaarj Scout
Posts: 21
Joined: 28 Feb 2010, 05:32

Subject:

Post Posted: 01 Mar 2010, 02:13

Waffnuffly wrote:I found something else interesting on Vista here at work. If you right click the UT exe, go to Compatibility, and then put a check next to "Disable Desktop Composition," the game no longer runs in turbo mode super speed.


This, more than anything else, made a huge difference for me. I'm running a vista laptop with an intel dual core in high-performance power mode. My game speed was actually slowing down, but only in certain areas of the maps I played. Changing the frame limit did nothing for me, and when I changed the performance mode, it only dropped my framerate a ton. Ty for that suggestion, finally fixed that issue for me. :)

User avatar Semfry
Trustee Member Trustee Member
Posts: 2002
Joined: 12 Nov 2007, 02:43
Location: UK
Contact:

Subject:

Post Posted: 01 Mar 2010, 17:31

I've added it to the OP now.

On Window 7 the game seemed to pretty much work straight away for me though (on both Intel and AMD, although I think I needed the dual core fix for the latter).

User avatar gatecrasher48
Skaarj Scout Skaarj Scout
Posts: 21
Joined: 28 Feb 2010, 05:32

Subject:

Post Posted: 01 Mar 2010, 20:06

Bummer, same occasional slow-speed problem turning up again. Can someone shed some light on exactly how changing the framerate limit works? I thought that only affected lag, not actual game speed. Or are those one in the same?

Next

Who is online

Users browsing this forum: No registered users and 5 guests