Scout-kun is a lie... right?

Enable Oldskool client-side cheating in old Unreal maps?

For gameplay advice and broader discussion of single-player Unreal including custom maps, mods and mutations that alter the game.

Moderators: ividyon, Semfry, zYnthetic

Ironword
Skaarj Warrior Skaarj Warrior
Posts: 69
Joined: 12 Mar 2016, 20:17

Subject: Enable Oldskool client-side cheating in old Unreal maps?

Post Posted: 12 Aug 2017, 22:47

How can you force an old Unreal map to allow cheating in UT/Oldskool when it doesn't work?

You know what I mean. Sometimes you've just got to summon a flashlight, or ghost yourself out of a place you shouldn't be stuck in. Or in my case, I've got a bad case of Nali-Weapons-3 jitters and I want to throw my ASMD and replace it with a bolt rifle. But I've noticed that in some Unreal maps opened with Oldskool, some (or who knows, maybe all; I haven't done any systematic experimentation) console commands don't work. Case in point: I'm currently playing DavidM's early effort "The Crash", notable for the Skaarj suit. In the first map everything worked fine. But now suddenly in the second map I can't summon a dang thing, not from NW3 nor even a regular Unreal item. Nor can ghost, fly, etc. UT mutators specified in the active list do work, but apparently no console commands (though I haven't tried to load a mutator via console). The same behavior occurs whether I play through the first map and auto-load into the second, or whether I load the second map manually. Worse, if I summon NW3 weapons in map 1 so I'll have them on map 2, and thus workaround the summoning failure in map 2, it doesn't work. When you autoload from map 1 to 2, you lose all items.

I've noticed the summoning problem in other old Unreal maps when opened in Oldskool, although sometimes it's the opposite: sometimes mutators won't work but console commands do. As one or the other happens more often than I'd like, I decided not to ignore it any longer and ask if there's anything that I can do about it.

So, does anyone know why this happens, and if it's possible to correct (easily, without going into UED and making actual changes in the maps)? If this is a very old topic hashed out long ago, please feel free to just point me to relevant material.

bob
Skaarj Lord Skaarj Lord
Posts: 204
Joined: 23 Apr 2011, 02:24
Location: USA
Contact:

Subject: Re: Enable Oldskool client-side cheating in old Unreal maps?

Post Posted: 14 Aug 2017, 18:00

since no one answered, ill say what i guess.
there is only 2 reasons this can happen.
reason 1: player pawn was replaced with a custom version that the auther decided to blank out cheat functions for.this would be especially true for "cutscences" or cases of custom playermodels, or a special gamemodes.

reason2 - usually occuring more in net games, but can happen elsewhere:
somthing in the map is corrupt; most notably the scripts.
either there were changes and remained uncompiled. or there could be broken sounds.
this usually breaks the replication chain and causes those command ( but not the native commans like quit etc)

Ironword
Skaarj Warrior Skaarj Warrior
Posts: 69
Joined: 12 Mar 2016, 20:17

Subject: Re: Enable Oldskool client-side cheating in old Unreal maps?

Post Posted: 20 Aug 2017, 10:05

So I guess there's nothing that can be done. But many thanks for the info.

User avatar Buff Skeleton
>:E >:E
Posts: 4069
Joined: 15 Dec 2007, 00:46

Subject: Re: Enable Oldskool client-side cheating in old Unreal maps?

Post Posted: 20 Aug 2017, 16:19

Seems weird that a map/script would be able to deny cheating, since that's an engine-level thing and not just a PlayerPawn thing, I'd think. I do remember that you used to have to type "iamtheone" before cheats would actually be enabled if you were running really old versions of UT. Maybe give that a shot and see if it allows you do to the usual god / ghost / fly etc. commands after that.
Image

Ironword
Skaarj Warrior Skaarj Warrior
Posts: 69
Joined: 12 Mar 2016, 20:17

Subject: Re: Enable Oldskool client-side cheating in old Unreal maps?

Post Posted: 21 Aug 2017, 08:23

Natch. I remembered the 'iamtheone' issue and tried it before posting. But thx for the suggestion.

User avatar UBerserker
Nali Priest Nali Priest
Posts: 7593
Joined: 11 Nov 2007, 21:00
Contact:

Subject: Re: Enable Oldskool client-side cheating in old Unreal maps?

Post Posted: 21 Aug 2017, 22:32

Yeah I clearly remember having the same issue with The Crash, probably because it makes use of a pre-placed playerpawn in the map. I don't think there's a quick workaround unless you decide to edit the map yourself and get rid of the playerpawn, so the transition from map 1 to 2 works normally (as long as playerstarts/teleporters are placed).
Image

User avatar Buff Skeleton
>:E >:E
Posts: 4069
Joined: 15 Dec 2007, 00:46

Subject: Re: Enable Oldskool client-side cheating in old Unreal maps?

Post Posted: 22 Aug 2017, 00:41

I remember Deus Ex had you in a position where you had to explicitly call a set command in the console to your player class and set bCheatsEnabled to true. Same engine, different context, but something similar might work.

Try putting "set PlayerPawn bCheatsEnabled True" in the console. Unreal's PlayerPawn class has the same variable (as expected, since Deus Ex probably extends this class rather than reinventing the wheel). Then you may be able to do normal cheats or "iamtheone" and then go from there?

You may have to go as far as "set UnrealShare.MaleThree bCheatsEnabled True" or whatever your player class is to get it to work, as I recall you had to do a "set DeusEx.JCDentonMale bCheatsEnabled True" in DX. Never tried just calling PlayerPawn, though, so that might work.
Image

Ironword
Skaarj Warrior Skaarj Warrior
Posts: 69
Joined: 12 Mar 2016, 20:17

Subject: Re: Enable Oldskool client-side cheating in old Unreal maps?

Post Posted: 23 Aug 2017, 03:28

UBerserker, thx for the input. And...

Try putting "set PlayerPawn bCheatsEnabled True" in the console

...that worked! Buff, may your bones grow muscles someday. Thanks much.


Who is online

Users browsing this forum: No registered users and 6 guests