Scout-kun is a lie... right?

Oldskool saves getting broken

For gameplay advice and broader discussion of single-player Unreal including custom maps, mods and mutations that alter the game.

Moderators: Semfry, zYnthetic, ividyon

Diego96
Skaarj Warrior Skaarj Warrior
Posts: 76
Joined: 13 Apr 2014, 19:36
Location: South 'Merica

Subject: Oldskool saves getting broken

Post Posted: 26 Nov 2017, 07:07

I've been playing different campaigns using UT99's oldskool but after a while I found that I cannot save in different categories for each campaign anymore, they save on the same general slot list:
Image
I'm using Lightning Hunter's CustomOldSkoolEntriesV12 and oldskool_noshadows. Maybe the culprits are the overwritten (but old) saves from Nali Chronicles (first 4 ones), the quicksaves or something else. This happened before but it went back to normal and now it's stuck again. I can provide more info if needed.

User avatar Lightning Hunter
Skaarj Elder Skaarj Elder
Posts: 1264
Joined: 11 Nov 2007, 22:12
Location: Pervert.

Subject: Re: Oldskool saves getting broken

Post Posted: 27 Nov 2017, 03:08

I remember this happening once, but I don't recall what the solution was. I think it might have had something to do with too many old saved games in the folder. How many files are in your UnrealTournament\Save folder?
For High-Res Unreal skins, click here.
For the RTNP "Ultimate Edition" HD, click here.

Image

Diego96
Skaarj Warrior Skaarj Warrior
Posts: 76
Joined: 13 Apr 2014, 19:36
Location: South 'Merica

Subject: Re: Oldskool saves getting broken

Post Posted: 27 Nov 2017, 03:34

Lightning Hunter wrote:I remember this happening once, but I don't recall what the solution was. I think it might have had something to do with too many old saved games in the folder. How many files are in your UnrealTournament\Save folder?

Like 175 but Oldskool looks like it could take up to 4000.

User avatar Lightning Hunter
Skaarj Elder Skaarj Elder
Posts: 1264
Joined: 11 Nov 2007, 22:12
Location: Pervert.

Subject: Re: Oldskool saves getting broken

Post Posted: 27 Nov 2017, 03:43

Diego96 wrote:
Lightning Hunter wrote:I remember this happening once, but I don't recall what the solution was. I think it might have had something to do with too many old saved games in the folder. How many files are in your UnrealTournament\Save folder?

Like 175 but Oldskool looks like it could take up to 4000.


In my oldskool.ini, I actually see a limit of 255. However, I don't think that is your issue. When was the last time you deleted your saved games or refreshed them? If they are really old, it is possible your oldskool.ini file got confused when you installed my olcustomentries. You could try deleting the "Packsaves" section (255 lines or so) in oldskool.ini and see if that helps. Just backup your original file before modifying it! You might also have to delete all old saved games in the \Save folder if nothing else works. If you have vital saved games recently used, you could try keeping those and deleting the rest (the date modified time stamp should tell you which savegame is which).
For High-Res Unreal skins, click here.
For the RTNP "Ultimate Edition" HD, click here.

Image

Diego96
Skaarj Warrior Skaarj Warrior
Posts: 76
Joined: 13 Apr 2014, 19:36
Location: South 'Merica

Subject: Re: Oldskool saves getting broken

Post Posted: 27 Nov 2017, 05:24

Lightning Hunter wrote:
Diego96 wrote:
Lightning Hunter wrote:I remember this happening once, but I don't recall what the solution was. I think it might have had something to do with too many old saved games in the folder. How many files are in your UnrealTournament\Save folder?

Like 175 but Oldskool looks like it could take up to 4000.


In my oldskool.ini, I actually see a limit of 255. However, I don't think that is your issue. When was the last time you deleted your saved games or refreshed them? If they are really old, it is possible your oldskool.ini file got confused when you installed my olcustomentries. You could try deleting the "Packsaves" section (255 lines or so) in oldskool.ini and see if that helps. Just backup your original file before modifying it! You might also have to delete all old saved games in the \Save folder if nothing else works. If you have vital saved games recently used, you could try keeping those and deleting the rest (the date modified time stamp should tell you which savegame is which).

Still haven't fixed it but I realised that the dropdown list of campaigns displays duplicates, maybe that's part of the same bug.

User avatar Lightning Hunter
Skaarj Elder Skaarj Elder
Posts: 1264
Joined: 11 Nov 2007, 22:12
Location: Pervert.

Subject: Re: Oldskool saves getting broken

Post Posted: 27 Nov 2017, 05:27

Sounds like something wacky is going on with oldskool.ini. It might need to be deleted and refreshed.
For High-Res Unreal skins, click here.
For the RTNP "Ultimate Edition" HD, click here.

Image

Diego96
Skaarj Warrior Skaarj Warrior
Posts: 76
Joined: 13 Apr 2014, 19:36
Location: South 'Merica

Subject: Re: Oldskool saves getting broken

Post Posted: 27 Nov 2017, 07:16

Lightning Hunter wrote:
Diego96 wrote:
Lightning Hunter wrote:I remember this happening once, but I don't recall what the solution was. I think it might have had something to do with too many old saved games in the folder. How many files are in your UnrealTournament\Save folder?

Like 175 but Oldskool looks like it could take up to 4000.


In my oldskool.ini, I actually see a limit of 255. However, I don't think that is your issue. When was the last time you deleted your saved games or refreshed them? If they are really old, it is possible your oldskool.ini file got confused when you installed my olcustomentries. You could try deleting the "Packsaves" section (255 lines or so) in oldskool.ini and see if that helps. Just backup your original file before modifying it! You might also have to delete all old saved games in the \Save folder if nothing else works. If you have vital saved games recently used, you could try keeping those and deleting the rest (the date modified time stamp should tell you which savegame is which).

All the packsaves are already in use (many of them using the same names). Deleting oldskool.ini crashes the game and deleting packsaves lines makes it ignore the saves.

Edit: I deleted the repeated lines next to all packsaves= (and not the part before the "=") and now the empty saves show in each campaign but still cannot save normally.

Edit 2: I think it's working.

User avatar Lightning Hunter
Skaarj Elder Skaarj Elder
Posts: 1264
Joined: 11 Nov 2007, 22:12
Location: Pervert.

Subject: Re: Oldskool saves getting broken

Post Posted: 27 Nov 2017, 08:10

I was going to say, if deleting oldskool.ini makes the game crash, then you might have to get the original oldskool.ini from the mutator installation. But it sounds like you got it working anyway.
For High-Res Unreal skins, click here.
For the RTNP "Ultimate Edition" HD, click here.

Image

Diego96
Skaarj Warrior Skaarj Warrior
Posts: 76
Joined: 13 Apr 2014, 19:36
Location: South 'Merica

Subject: Re: Oldskool saves getting broken

Post Posted: 27 Nov 2017, 17:05

Lightning Hunter wrote:I was going to say, if deleting oldskool.ini makes the game crash, then you might have to get the original oldskool.ini from the mutator installation. But it sounds like you got it working anyway.

You were right but I needed to delete the description of each column using the Alt key instead. I successfully tested 4 different campaigns. :)

User avatar Lightning Hunter
Skaarj Elder Skaarj Elder
Posts: 1264
Joined: 11 Nov 2007, 22:12
Location: Pervert.

Subject: Re: Oldskool saves getting broken

Post Posted: 27 Nov 2017, 19:47

That's good. Sometimes oldskool.ini gets corrupted if you install/modify a lot of campaigns. This would especially be true for someone that used it for years before installing my olcustomentries (which changes everything around).
For High-Res Unreal skins, click here.
For the RTNP "Ultimate Edition" HD, click here.

Image


Who is online

Users browsing this forum: No registered users and 4 guests