Could be asleep, typing random messages instead.

Version 5.00 [10-11-12]

For public discussion of all things EXU2.

Moderator: Buff Skeleton

User avatar shawnd123
Skaarj Lord Skaarj Lord
Posts: 240
Joined: 29 Oct 2009, 04:07
Location: That one place

Subject: Re: == Version 5.00 [10-11-12] --- Bug Reports & Discussion Thread ==

Post Posted: 13 Oct 2012, 15:02

jaypeezy wrote:So, the only bug I've noticed. And this might just be a problem with my graphics or something, but a few of the blood spray decals don't seem to be set as masked, so they show up as black squares with the blood splat in the middle. It doesn't really happen so often, though.

I don't think I encountered that problem yet, I'm using OpenGL here. The decals are looking gorgeous, btw. Such a bloody beauty.
Image Image

User avatar jaypeezy
Skaarj Berserker Skaarj Berserker
Posts: 314
Joined: 25 Sep 2010, 04:32

Subject: Re: == Version 5.00 [10-11-12] --- Bug Reports & Discussion Thread ==

Post Posted: 13 Oct 2012, 16:45

shawnd123 wrote:
jaypeezy wrote:So, the only bug I've noticed. And this might just be a problem with my graphics or something, but a few of the blood spray decals don't seem to be set as masked, so they show up as black squares with the blood splat in the middle. It doesn't really happen so often, though.

I don't think I encountered that problem yet, I'm using OpenGL here. The decals are looking gorgeous, btw. Such a bloody beauty.


So the other thing I forgot to mention was I'm not using D3d10 because I'm missing some driver or it gives me errors; nor EXUOpenGL because it causes speed problems for me. :/

User avatar Buff Skeleton
>:E >:E
Posts: 4104
Joined: 15 Dec 2007, 00:46

Subject: Re: == Version 5.00 [10-11-12] --- Bug Reports & Discussion Thread ==

Post Posted: 13 Oct 2012, 18:02

Which renderer are you using? You may want to try D3D10 or EXUOpenGL anyway because Map 19 and other huge maps absolutely will require uncapped drawdistance, but you can get away with a different renderer at least until then.

Also, screenshots of the unmasked decals would help; I could identify which textures are doing it and see if they are missing flags or something that maybe my renderer auto-corrects.

What errors do you get with D3D10?
Image

redeye
Banned Banned
Posts: 1393
Joined: 08 Dec 2007, 06:55

Subject: Re: == Version 5.00 [10-11-12] --- Bug Reports & Discussion Thread ==

Post Posted: 13 Oct 2012, 18:40

Glad you moved all this to it's own section on the forums, good move :P
Just ban everyone

User avatar jaypeezy
Skaarj Berserker Skaarj Berserker
Posts: 314
Joined: 25 Sep 2010, 04:32

Subject: Re: == Version 5.00 [10-11-12] --- Bug Reports & Discussion Thread ==

Post Posted: 13 Oct 2012, 21:26

Waffnuffly wrote:What errors do you get with D3D10?


Image
...on UT:GOTY with the v436 no-delta update. Downloaded all additional materials from the D3D10 webpage you linked to elsewhere.

As for the unmasked blood decals, I'll be sure to take some pictures of those next time I see them.

At the moment I'm using the default Direct3D rendering that comes when you just installed UT for the first time. Got a new machine here. And, I don't know if it's the changes you've made, the new computer, or both, but other than those few decals - and some errors in drawdistance, clearly - EXU has been running noticeably better on it. Shit grenades don't lag my machine to high hell. :tup:

Another weird thing that might be of some importance: I've only really noticed the unmasked black-square error with red and orange blood. Everything else is just fine so far...

User avatar Buff Skeleton
>:E >:E
Posts: 4104
Joined: 15 Dec 2007, 00:46

Subject: Re: == Version 5.00 [10-11-12] --- Bug Reports & Discussion Thread ==

Post Posted: 13 Oct 2012, 22:42

EUEUEUEUUUGGH don't use the stock D3D renderer, that is by far the worst. At least use OpenGL if not EXUOpenGL.

Are you sure you have the latest DirectX installed? I can't think of any other reason Direct3D would just outright crash.
Image

User avatar jaypeezy
Skaarj Berserker Skaarj Berserker
Posts: 314
Joined: 25 Sep 2010, 04:32

Subject: Re: == Version 5.00 [10-11-12] --- Bug Reports & Discussion Thread ==

Post Posted: 14 Oct 2012, 00:37

Waffnuffly wrote:EUEUEUEUUUGGH don't use the stock D3D renderer, that is by far the worst. At least use OpenGL if not EXUOpenGL.

Are you sure you have the latest DirectX installed? I can't think of any other reason Direct3D would just outright crash.


But when I use OpenGL, it fucks up the speed in-game and it runs too fast infrequently. :/
I just checked and I have version 11 installed.

EDIT: According to another post of yours, Waff, I went and tried D3D9 and that one DOES work... which I find odd but, I used that one and didn't seen any decal bugs during the two places I did see them (both heavy, bloody fights). The website you linked to over there in that post, to download D3D10, said it won't work with Intel integrated graphics. My laptop uses an Intel 4000 HD Graphics card... I wonder if that has anything to do with it. :shake:

User avatar Buff Skeleton
>:E >:E
Posts: 4104
Joined: 15 Dec 2007, 00:46

Subject: Re: == Version 5.00 [10-11-12] --- Bug Reports & Discussion Thread ==

Post Posted: 14 Oct 2012, 01:23

Ah, yeah, that would do it. As for UT running too fast with OpenGL, there's a thread in General Gameplay about that.
Image

User avatar jaypeezy
Skaarj Berserker Skaarj Berserker
Posts: 314
Joined: 25 Sep 2010, 04:32

Subject: Re: == Version 5.00 [10-11-12] --- Bug Reports & Discussion Thread ==

Post Posted: 14 Oct 2012, 06:11

Another thing I noticed is that, in Deathmatch, if players/bots use the hellgun secondary on eachother it does no damage at all.

ANOTHER EDIT: I ended up getting d3d10 to work. I was missing a file, apparently. HOLY SHIT, nicest looking one by far but slows me down plenty.

User avatar Buff Skeleton
>:E >:E
Posts: 4104
Joined: 15 Dec 2007, 00:46

Subject: Re: == Version 5.00 [10-11-12] --- Bug Reports & Discussion Thread ==

Post Posted: 14 Oct 2012, 18:02

jaypeezy wrote:Another thing I noticed is that, in Deathmatch, if players/bots use the hellgun secondary on eachother it does no damage at all.


Ah, deathmatch. I thought you were referring to CTF or team games, where the alt fire is supposed to ignore friendlies. I tested the DM bug and confirmed it, so I'll have that fixed next patch.

[Edit] fixed
Image

User avatar jaypeezy
Skaarj Berserker Skaarj Berserker
Posts: 314
Joined: 25 Sep 2010, 04:32

Subject: Re: == Version 5.00 [10-11-12] --- Bug Reports & Discussion Thread ==

Post Posted: 14 Oct 2012, 22:29

Awesome! Yeah, and besides that the only other weapons bug I noticed was the exu-shotty, which doesn't cause me damage when used by bots.

Would you happen to know how to set UT DM so that the flares don't automatically get activated when you run over them?

User avatar Buff Skeleton
>:E >:E
Posts: 4104
Joined: 15 Dec 2007, 00:46

Subject: Re: == Version 5.00 [10-11-12] --- Bug Reports & Discussion Thread ==

Post Posted: 14 Oct 2012, 22:45

No, and I don't think that would really be viable either unless bot AI was able to handle them too. Without a genius scripter onboard, I can't imagine that ever happening. It's better to just have them as opportunistic loosely-controlled chaos generators, I think.
Image

User avatar UBerserker
Nali Priest Nali Priest
Posts: 7659
Joined: 11 Nov 2007, 21:00
Contact:

Subject: Re: == Version 5.00 [10-11-12] --- Bug Reports & Discussion Thread ==

Post Posted: 15 Oct 2012, 12:01

Hehe, looks I decided to open the editor directly instead. A bit overwhelmed by the new quantity of actors and updated ones :) Feels like using a real game toolkit like UDK

Trying to figure out the camera/security trigger thing.

ShockTrooper/Command are bugged when they die in the water. They explode but their body is still there with their last animation frozen.

By the way can you deactivate the Hell Hoes throughout Triggers or they're just a one-time-activation thing which lives forever?
Also regarding the EXUScriptedTriggers... are they supposed to repeat events? I mean, I need to have an Event retriggered after xx time. Setting BLoopScript=False, LoopDelay=time I need, Script=The event(?) - Is the EXUScriptedTrigger good for that? Unless the Dispatcher is good enough but I want to use EXU actors.

Boss Tags? Do those still require specific textures with the written Boss Name?
Last edited by UBerserker on 15 Oct 2012, 14:06, edited 1 time in total.
Image

User avatar Gizzy
Skaarj Berserker Skaarj Berserker
Posts: 449
Joined: 02 Feb 2010, 12:55

Subject: Re: == Version 5.00 [10-11-12] --- Bug Reports & Discussion Thread ==

Post Posted: 15 Oct 2012, 13:49

In the first map (VRikers) when you go down the corridor where the wire hangs down and damages the player, It's invisible for me, but I can still hear it buzzing and it damages me.

User avatar Buff Skeleton
>:E >:E
Posts: 4104
Joined: 15 Dec 2007, 00:46

Subject: Re: == Version 5.00 [10-11-12] --- Bug Reports & Discussion Thread ==

Post Posted: 15 Oct 2012, 17:24

Gizzy wrote:In the first map (VRikers) when you go down the corridor where the wire hangs down and damages the player, It's invisible for me, but I can still hear it buzzing and it damages me.

Renderer? Renderer settings posted to pastebin.com? Video hardware?

I can't tell you what the problems might be with visual stuff unless you give me details!


UBerserker wrote:ShockTrooper/Command are bugged when they die in the water. They explode but their body is still there with their last animation frozen.

Can't reproduce this. What renderer / settings are you using and under what circumstances does this happen?
[Edit] Happens in Oldskool SP games with the Oldskool gametype. Oldskool's carcass override causes it. I can fix it by doing my own override, but I'll see how many classes actually need this done before I decide to start doing further Oldskool workarounds.

By the way can you deactivate the Hell Hoes throughout Triggers

Yeah. They are toggleable.

Also regarding the EXUScriptedTriggers... are they supposed to repeat events? I mean, I need to have an Event retriggered after xx time. Setting BLoopScript=False, LoopDelay=time I need, Script=The event(?) - Is the EXUScriptedTrigger good for that? Unless the Dispatcher is good enough but I want to use EXU actors.

Honestly, I don't know much about ScriptedTrigger as that was UA's domain. I'd just use an EXUDispatcher set to loop X times (or infinite) and give it a proper delay at the end of the dispatch cycle.

Boss Tags? Do those still require specific textures with the written Boss Name?

Yes. Boss trigger stuff is unchanged for now.
Image

Previous Next

Who is online

Users browsing this forum: No registered users and 1 guest