ividyon will never get this done, will he.

Required ServerPackages, EXU2 Server

For public discussion of all things EXU2.

Moderator: Buff Skeleton

User avatar jaypeezy
Skaarj Berserker Skaarj Berserker
Posts: 310
Joined: 25 Sep 2010, 04:32

Subject: Required ServerPackages, EXU2 Server

Post Posted: 03 Jan 2016, 17:28

So, here it is: I'm starting an EXU2 server. Not a temporary thing, a stand-alone, 24/7 place for us all to splatter the place up.

However, I'm running into more walls than expected. I'd really like to have this server up and running flawlessly before I started announcing it, but oh well.

Anyway, server packages: I think I have them all listed, but here they are:

Code: Select all

ServerPackages=Editor
ServerPackages=SoldierSkins
ServerPackages=CommandoSkins
ServerPackages=FCommandoSkins
ServerPackages=SGirlSkins
ServerPackages=BossSkins
ServerPackages=Botpack
ServerPackages=MultiMesh
ServerPackages=Relics
ServerPackages=EpicCustomModels
ServerPackages=TCowMeshSkins
ServerPackages=TNaliMeshSkins
ServerPackages=De
ServerPackages=SkeletalChars
ServerPackages=RocketArena
ServerPackages=RocketArenaMedia
ServerPackages=RocketArenaMultiMesh
ServerPackages=oldskool
ServerPackages=olroot
ServerPackages=olweapons
ServerPackages=oldskoolra
ServerPackages=EXU2BI
ServerPackages=EXU
ServerPackages=UARain
ServerPackages=uelite


Seems simple enough, like things should work just fine. I've done this hundreds of time when setting up a local server, right? Wrong. I keep getting this error:

Log: Server Package: oldskoolra
Log: Failed import: Class Class Oldskool.Oldskool (file ../System/Oldskool.u)
Warning: Failed to load 'oldskoolra': Can't find Class in file 'Class Oldskool.Oldskool'
Critical: appError called:
Critical: Failed to load 'oldskoolra': Can't find Class in file 'Class Oldskool.Oldskool'
Exit: Executing UObject::StaticShutdownAfterError
Critical: UObject::SafeLoadError
Critical: UObject::GetPackageLinker
Critical: UGameEngine::BuildServerMasterMap
Critical: ULevel::Listen
Critical: Listen
Critical: UGameEngine::LoadMap
Critical: LocalMapURL
Critical: UGameEngine::Browse
Critical: UGameEngine::Init
Critical: UServerCommandlet::Main
Exit: Exiting.
Uninitialized: Name subsystem shut down
Uninitialized: Log file closed, 01/03/16 11:25:56


Totally stumped. Judging by the error message oldskoolra is looking for a class in the Oldskool package (also named Oldskool) that doesn't exist. So, maybe I'm not using the right version of Oldskool (except I used the one that came with the EXU2 v6 install :| )

I'm unsure on whether I need oldskoolra/its dependencies, because when I remove those then I get some new errors. As in, map loads fine, no HUD displays, eventually breaks the game errors.

User avatar Buff Skeleton
>:E >:E
Posts: 4065
Joined: 15 Dec 2007, 00:46

Subject: Re: Required ServerPackages, EXU2 Server

Post Posted: 03 Jan 2016, 19:33

You don't need Oldskool in there at all. Here's what I've got in mine, with nonessentials removed:

Code: Select all

ServerPackages=SoldierSkins
ServerPackages=CommandoSkins
ServerPackages=FCommandoSkins
ServerPackages=SGirlSkins
ServerPackages=BossSkins
ServerPackages=Botpack
ServerPackages=VRikers
ServerPackages=AmbOutside
ServerPackages=AmbModern
ServerPackages=AmbAncient
ServerPackages=EXU-Sounds
ServerPackages=EXU-Textures
ServerPackages=EXU
ServerPackages=EXU2BI
ServerPackages=UELite
ServerPackages=UARain
ServerPackages=soldierskins_blackguard
Image

User avatar jaypeezy
Skaarj Berserker Skaarj Berserker
Posts: 310
Joined: 25 Sep 2010, 04:32

Subject: Re: Required ServerPackages, EXU2 Server

Post Posted: 03 Jan 2016, 20:28

Thanks again. It turns out the thing that's giving me a damn headache is LAMapVote13. Otherwise traveling from one map to the next work as expected. Someone even managed to find my server and play for a few hours last night... not sure how they found it, but cool!

medor
Skaarj Lord Skaarj Lord
Posts: 150
Joined: 07 Jun 2009, 22:58

Subject: Re: Required ServerPackages, EXU2 Server

Post Posted: 05 Jan 2016, 14:02

Not need that
ServerPackages=De
It's only for mismatch


Who is online

Users browsing this forum: No registered users and 2 guests